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Merge Rule Basics in Alma

1. Roles Required to merge bib records in Alma: 

a) Cataloger

b) Cataloger Extended role

2. NZ Records in Alma match on the OCLC # 

3. Merging records can occur upon:

a) Importing bib records using an import profile or API integration profile

a) Multi-matches are merged based on how it is configured

b) Import bib records from OCLC

i. OCLC Export  - multiple records in the NZ with the same OCLC # cannot be exported

ii. OCLC Nightly Jobs: multi-matches are either automatically or manually merged and the 

inventory is combined

c) Merging two existing bib records in the MD Editor

d) Copy cataloging using External Resources in the MD Editor 



Merge Rule Basics in Alma

4. Merge rules are used to determine how matching bib records will be merged

5. Bib records need to be in the same zone to be merged

a) Matching records with the same OCLC maybe found in different zones, but “Merge 

Records and Combine Inventory” in the MD Editor will be grayed out

a) Example; IZ record will match to an NZ bib record with the same OCLC # if no matching IZ 

record exists

6. Merging two bib records will move all the associated inventory to the primary record (PO line, 

Physical items, Loans, Requests, Reading lists, Related record relationship)

7. There is always a primary and secondary record when merging



Primary and Secondary Record Behavior When Merging

1. Primary Record

a) Contains all the merged information

b) Merge rules either remove information in the primary record or copies information from 

the secondary record to the primary record

2. Secondary Record

a) Contains information that can be merged into the primary record

b) Merge rules do not change the secondary record

c) The secondary record should be deleted or else it remains in the repository causing a 

match to be found again



Primary Record Behavior When Merging



Possible Workflows to Merge a NZ Brief Bib with an NZ Bib Record

1. Merge Record & Combine Inventory - USE

Roles Required:

• Cataloger

• Cataloger Extended

Pros:

• Retains the POL and associated inventory

• Can deletes the secondary bib record

• Other campus holdings are merged 

• No duplicate bib records are created

Cons:

• Call number in the holdings record may need to be updated

• Change Bib Reference for the POL if title differs

• Records can be merged incorrectly if the incorrect merge routine is used



Possible Workflows to Merge a NZ Brief Bib with an NZ Bib Record

3. Copy and Merge – DO NOT USE 

Roles Required:

• Cataloger

• Cataloger Extended

Pros:

• Merges MARC fields in the primary and 

secondary records

• Maintains local notes

• Retains POL and associated inventory

Cons:

• Brief bib MARC fields are retained

• Does not merge inventory

• Creates a duplicate bib record in the NZ

• Call number in the holdings record needs to 

be updated

• Leaves user in a loop matching to the original 

full NZ bib record

2. Copy & Overlay – DO NOT USE 

Roles Required:

• Cataloger

• Cataloger Extended

Pros:

• Overlays all the MARC fields in brief bib 

with the secondary record’s MARC fields

• Retains POL and associated inventory

Cons:

• Does not merge inventory 

• Creates a duplicate bib record in the NZ

• Does not retain local notes

• Call number in the holdings record needs 

to be updated



OCLC Export Behavior with Matching OCLC Records

■ OCLC cannot export a bib record into Alma when there is more than one bib record with the 

same OCLC # it can match on

■ When you attempt to export a bib record to Alma with multiple matches you will get the 

following error:
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Match Configurations

The settings below were configured by the NZ Coordinator for your institution. They match the 

Network Zone (NZ) and they will reduce the number of matching records that will be found in the 

MD Editor:

1. Go to Configuration>Resources>General>Other Settings

2. The following fields in your IZ match the settings in the NZ

a) non_serial_match_profile: com.exlibris.repository.mms.match.OCLCMatchProfile

b) serial_match_profile: com.exlibris.repository.mms.match.OCLCSerialMatchProfile

c) Ignore_cz_records: true
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Merge vs. Overlay

1. Merge – as defined by Merriam-Webster dictionary “to cause to combine, unite, or coalesce”

a) Combines MARC fields from the secondary record with the primary record

b) Fields that are combined with the primary record depends on the merge rule

2. Overlay - as defined by Merriam-Webster dictionary “to lay or spread over or across”

a) Over-writes all MARC fields in the primary record with the MARC fields from the 

secondary record, including local notes



MERGE RULES



Merge Rules

■ Merge rules can:

a) Add  

b) Remove

c) Replace

■ Existing Ex Libris merge rules can be used, but you want to make sure to click on “show 
merge preview” to make sure the merge rule works as expected

a) Conditional subject headings –

i. Merges all fields from the secondary record to the primary record

ii. Retains the subject headings from the primary record, which may create duplicate subject 
headings

b) Keep only old value

i. Retains only the fields in the primary record, including local fields

c) Overlay all but local fields –

i. Overlays all MARC fields in the primary record with the secondary record

ii. Retains the local fields in the primary record

d) Replace 245 and 035 OCoLC if exist –it will replace the 245 and 035 in the secondary 
record with the 245 and 035 from the primary record 



Merge Rules

■ Campuses can create their own merge rules if  an 

existing merge rules does not meet their needs

– IZ only records require an IZ merge rule

– NZ records require an NZ merge rule

■ To create a merge rule to use with NZ bib records

– The “Placement of new rules” needs to be set to 

Network

■ To create a merge rule to use with IZ bib only bib records

– The “Placement of new rules” needs to be set to 

Local



MERGE RECORDS AND 
COMBINE INVENTORY 

WORKFLOW



Merge Records and Combine Inventory Workflow

The following message will appear if there is a matching record while updating a bib record in the 

MD Editor after saving or saving and releasing the record:

You can do one of the following things:

1. Click Yes

2. Click No



CHOOSING “YES” WHEN A 
MATCH IS FOUND 

WORKFLOW



Merge Records and Combine Inventory Workflow

Choosing “Yes” in the MD Editor when a match is 
found worklfow:

1. Click Yes when the following confirmation
message appears: “Matched record/s exist in the 
catalog, do you want to view them before 
saving?”

2. Both records will display in the MD Editor



Merge Records and Combine Inventory Workflow

3. Click View from the secondary record

a) Viewing the record allows you to determine which should be the primary record

b) The primary record may not be as big of a concern because bib records are matching 

on the OCLC #



Merge Records and Combine Inventory Workflow

4. Make sure the middle drop-down box is on Edit

5. Click Execute after viewing the bib record

a) Execute opens the record in the MD Editor so that is can be edited



Merge Records and Combine Inventory Workflow

6. Go to Tools>MARC Bibliographic>Merge Records & Combine Inventory



Merge Records and Combine Inventory Workflow

7. The Merge Records & Combine Inventory screen pops-up

a) Choose merge routine: [select the merge rule]

b) Click “Show merge preview”

i. Preview the merge behavior

ii. Click Ok



Merge Records and Combine Inventory Workflow

7. The Merge Records & Combine Inventory continued

c) Update holdings call number 

i. Depends on the merge routine and if the 

holdings call number needs to be updated

d) Secondary record: Delete

i. Always select delete so the duplicate bib record 

no longer exists in the NZ

e) Click Ok

8. The newly merged bib record opens in the MD Editor

9. Click File>Save and Release Record (Ctrl+Alt+R)



CHOOSING “NO” WHEN A 
MATCH IS FOUND 

WORKFLOW



Merge Records and Combine Inventory Workflow

Choosing “No” in the MD Editor when a match is found 

workflow:

1. Click “No” when the confirmation box appears with the 

following message” “Matched record/s exist in the 

catalog, do you want to view them before saving?

2. Copy the OCLC # from the record in the MD Editor

3. Click Back (<)

a) Do not release the bib record from the MD Editor

4. Perform an All Titles repository search by Other System 

Number



Merge Records and Combine Inventory Workflow

5. Click Edit Record from the matching bib record that is not linked to the IZ

6. Click on the Split Screen icon



Merge Records and Combine Inventory Workflow

5. Click into the right-side of the MD Editor

6. Click on the NZ linked bib record from Records>MARC21 Bibliographic



Merge Records and Combine Inventory Workflow

7. Both records open in the MD Editor

a) See the workflow on how to make a secondary record a primary record if applicable

8. Continue with the Merge Records & Combine Inventory Workflow



HOW TO MAKE THE 
SECONDARY RECORD THE 

PRIMARY RECORD



Merge Records and Combine Inventory Workflow

When you want to make the secondary record the primary record

1. After viewing the secondary record make sure the middle drop-down box is on Edit then click 

Execute



Merge Records and Combine Inventory Workflow

2. Click into the right-screen of the MD Editor with the secondary record

3. Click on the Split Screen icon

a) This will open the secondary record into the main screen of the MD Editor

b) The previous primary record will still be “locked” and found under Records>MARC21 

Bibliographic



Merge Records and Combine Inventory Workflow

4. Click on the Split Screen Icon

5. Click on the right-screen of the MD Editor

6. Click on the “original” primary record from Records>MARC21 Bibliographic



Merge Records and Combine Inventory Workflow

7. Both records will display in the MD Editor

8. Continue with the Merge Records and Combine Inventory workflow



MERGE WORKFLOW FOR 
WHEN THERE IS MORE 
THAN ONE MATCHING 

RECORD



Merge Records and Combine Inventory Workflow

When there is more than one matching bib record

1. Click Yes when the following confirmation message 

appears: “Matched record/s exist in the catalog, do 

you want to view them before saving?”

2. All records will display in the MD Editor



Merge Records and Combine Inventory Workflow

3. Click View each record



Merge Records and Combine Inventory Workflow

4. Click Back to Results to view the other record and/or to select the record to merge with



Merge Records and Combine Inventory Workflow

5. Click Edit from the record that has been chosen to be merged with



Merge Records and Combine Inventory Workflow

6. Go to Tools>MARC Bibliographic>Merge Records & Combine Inventory



Merge Records and Combine Inventory Workflow

7. The Merge Records & Combine Inventory screen pops-up

a) Choose merge routine: [select the merge rule]

b) Click “Show merge preview”

i. Preview the merge behavior

ii. Click Ok



Merge Records and Combine Inventory Workflow

7. The Merge Records & Combine Inventory continued

c) Update holdings call number

i. Depends on the merge routine and if the 

holdings call number should be updated

d) Secondary record: Delete

e) Click Ok

8. The newly merged bib record opens in the MD Editor

9. Click File>Save (Ctrl+S) or File>Save and Release 

Record (Ctrl+Alt+R)



Merge Records and Combine Inventory Workflow

10. Confirmation box with the following message appears 

because there are more matching records: “Matched 

record/s exist in the catalog, do you want to view them 

before saving?”

a) Yes – follow the steps above to merge records

b) No – leaves two bib records with the same OCLC in 

the IZ or the NZ



Merge Records and Combine Inventory Workflow

■ If there is more than one matching  NZ record:

– Check to see if there if inventory on all the NZ bib records

■ Perform a repository search by “Other System Number”

– Submit the NZ record to be deleted to the NZ Coordinator if there is not inventory on a 

NZ bib record with the same OCLC #

■ Go to the SUNY Shared LSP Overview Libguide: https://slcny.libguides.com/

– Click Communication Channels

– Click Form and Contacts for SLSS

– Click Request to Delete to Delete NZ Bib Records

– Fill out the request form

https://slcny.libguides.com/


SUPPORTING 
DOCUMENTATION



Supporting Documentation

■ FAQ: How do I reduce the number of matching bib records a bib record is matching with in the 

MD Editor?

■ Ex Libris Documentation: Merging Bibliographic records

■ Ex Libris Documentation: Working with Merge Rules

■ Ex Libris Documentation: Configuring BIB Redirection Fields

https://slcny.libanswers.com/faq/270751
https://knowledge.exlibrisgroup.com/Alma/Product_Documentation/010Alma_Online_Help_(English)/040Resource_Management/040Metadata_Management/040Working_with_Bibliographic_Records#Merging_Bibliographic_Records
https://knowledge.exlibrisgroup.com/Alma/Product_Documentation/010Alma_Online_Help_(English)/040Resource_Management/040Metadata_Management/080Working_with_Merge_Rules
https://knowledge.exlibrisgroup.com/Alma/Product_Documentation/010Alma_Online_Help_(English)/040Resource_Management/080Configuring_Resource_Management/040Configuring_BIB_Redirection_Fields

