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Identify and Clean-up Bad Diacritics for IZ Only Bib Records

In this session we will cover:
1. Define bad/corrupted diacritics
2. Causes of bad/corrupted diacritics
3. How bad/corrupted diacritics are being updated in the NZ
4. How to identify bad/corrupted diacritics for IZ only bib records
5. How to update identified bib records with bad/corrupted diacritics
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Bad/Corrupted Diacritics Defined

• Diacritics are symbols that are above or below a 
character to indicate the character has a different 
pronunciation 

• Using the term diacritics in this session also includes 
special characters, such as the copyright symbol ©

• Bad/corrupted diacritics refer to characters containing 
symbols or special characters that do not display 
properly in Alma and/or Primo VE
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Causes of Bad/Corrupted Diacritics

• Alma cannot convert diacritics and special characters in 
bib records that are imported into Alma as MARC-8

• Connexion Client Settings:
o Record Characteristics for “Character Set” is not 

configured to UTF-8 (Tools>Options>Export tab>Record 
Characteristics) 

• Connexion Web Version:
o Records can only be imported into Alma as MARC-8

• Import Profiles:
o Encoding format is not configured to UTF-8
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How Bad/Corrupted Diacritics Are Being Updated for NZ Linked Records

• NZ linked physical bib records are monitored by the Network Zone Coordinator
o OCLC WorldShare files are monitored daily for corrupted diacritics/special characters 
o All NZ physical bib records are filtered monthly using an indication rule to identify corrupted 

diacritics/special characters
• NZ Physical bib record with corrupted diacritics/special characters are reimported into Alma daily:

o OCLC numbers (ocns) are batch imported into Connexion Client
o OCLC MARC records saved in batch to a local save file
o OCLC MARC records in the local save file are batch exported to a file
o OCLC file (.dat) is change to a .mrc file
o OCLC .mrc file is imported into Alma using an import profile without inventory
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Identifying Bad/Corrupted Diacritics for IZ Only Bib Records

Bad/Corrupted Diacritics for IZ only records can be identified by:
1. Indication rule
2. Analytics report 

Using an indication Rule Using an Analytics Report

• Requires a “Cataloger” user role 
• Can search all MARC fields
• Requires a set of records
• Requires a filter to be run on the set of records

• Requires a “Design Analytics” user role 
• Limited ability to search all MARC fields

o 5XXs and 9XXs cannot be searched unless they 
have been configured to Local Params by Ex Libris

o May result in bib records with corrupted characters 
remaining in the repository

• Can be added to the Alma dashboard as a report 
and/or widget
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Identifying Bad/Corrupted Diacritics for IZ Only Bib Records

Using an indication rule:
1. Open the MD Editor
2. Check the “placement of new rules” is 

set to local
• Click on Records or Templates 

tab>New>Placement options

3. Click on Rule>Indication
4. Search for the SUNY indication rule 

called: SUNY -Indication Rule for 
Corrupted Diacritics & Special 
Characters

5. Right-click on the indication rule and 
select Duplicate

1. Edit the Name
2. Click Save

7. Go to Admin>Manage Jobs and 
Sets>Manage Sets

8. Create a set of IZ only physical bib records 
using a repository search

9. Click Save and Filter Query
1. Name: Name the set
2. Description: [Optional]
3. Click Save and Filter
4. Filter: [Select the duplicated rule]
5. Name: [Edit to identify better]
6. Click Filter this set
7. Click Confirm

10.Review the records
1. Go to Admin>Manage Sets and 

Jobs>Manage Sets
2. Click Members from the ellipsis for the set
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Identifying Bad/Corrupted Diacritics for IZ Only Records

Using an analytics report:
1. Go Analytics>Analytics>Design 

Analytics
2. Go to the following path: /Shared 

Folders/Community/Reports/Consortia
/SUNY/Resource Management/Bib 
Records with Diacritic Errors at the 
Institution Level

3. Click Open to run the report directly 
from the path

4. Export the results for review
• Click Export>Formatted>Excel

NOTE: DO NOT make changes to the analytics reports. If an 
institution wants  to make changes, they need to save the file 
using “Save as” to the Institutions Reports path.
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Updating Bad/Corrupted Diacritics in IZ Only Bib Records

Updating corrupted characters in IZ only bib records:
1. With an OCLC number
2. Without an OCLC number

Updating IZ Only bib records without OCLC Numbers Updating IZ Only bib records with OCLC Numbers

• Manually:
o Make changes manually in the MD Editor

• Reimport the bib records into the IZ:
o Export records one by one from OCLC 
o Export a set of records to file and import them into 

Alma using a Repository Import Profile without 
inventory
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Updating IZ Only bib records without OCLC Numbers

To update IZ Only bib records in the MD Editor:
1. Open the bib record in the MD Editor
2. Correct the bad/corrupted diacritics

• Copy and paste
• Using the Windows built in character map

3. Go to Save>Save and Release the Record
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Updating IZ Only bib records without OCLC Numbers

Using the Windows built in character map:
1. Search for Character Map from the Windows search 

menu
• Or go to All Programs>Accessories>System 

Tools>Character Map  from the Windows start menu

2. Select a font from the Font drop-down list
3. Click on the special character
4. Click Select
5. Click Copy
6. Paste the character in the MD Editor
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Updating IZ Only Bib Records with OCLC Numbers Manually

Reimporting IZ Only bib records manually:
1. Open Connexion Client

▪ Do not use the Web version as it will not 
correct the corrupted characters

2. Verify the Character Set is configured to UTF-8
▪ Go to Tools>Options>Export tab>Record 

Characteristics

3. Configure the export to the Alma IZ export for 
your institution
1. Go to Tools>Options>Export tab 
2. Select the Alma IZ export
3. Click Apply
4. Click Close

4. Search for the bib record by OCLC number
5. Export the bib record into the IZ
6. Review the record was updated properly in 

Alma
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Updating IZ Only Bib Records with OCLC Numbers Using an Import Profile

Steps  to update IZ only bib record using an Import Profile 
1. Create an IZ Repository Import Profile without Inventory
2. Copy the OCLC numbers to a .txt file
3. Batch import the OCLC number to Alma
4. Batch load the MARC records to a local save file
5. Export the MARC records in the local save file to a file
6. Rename the file from .dat to .mrc
7. Import the .mrc file into Alma using the IZ Repository Import Profile
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1. Create a Repository Import Profile Without Inventory

1. Go to Resources>Import>Manage Import Profiles
2. Click Add New Profile
3. Select the radio button next to Repository
4. Click Next
5. Uncheck “Use Network Zone”
6. Name: [Name the Import Profile]
7. Profile Description: [Add description]
8. Originating System: [Select Other]
9. File Name Patterns: [Type .mrc]
10. Import Protocol: [Select Upload File/s]
11. Physical Source Format: [Select Binary]
12. Encoding Format: [Select UTF-8]
13. Source Format: [Select MARC21 Bibliographic]
14. Status: [Select Active]
15. Click Next
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1. Creating a Repository Import Profile Without Inventory

16. Filter: [Leave blank]
17. Correct the Data Using: [Select SUNY OCLC Normalization Rule]
18. Handle Invalid Data Using: [Select MarcXML Bib Import]
19. Click Next
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1. Creating a Repository Import Profile Without Inventory

20. Match by Serial Match Method: [Select No]
21. Match Method: [Select 035 (Other System Identifier) Match Method
22. System Identifier Prefix: [Type (OCoLC)
23. Handling Method: [Select Automatic]
24. Upon Match: [Select Overlay]
25. Single match - match only record with the same inventory type 

(electronic/physical): [Check box]
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1. Creating a Repository Import Profile Without Inventory

26. Merge Method: [Select SUNY - Overlay All But 
Local Fields]

27. Select Action: [Check the box for Prefer record 
with the same inventory type 
(electronic/physical)]

28. Merge and Combine: [Select Manually]
29. Preferred Record: [Select Record with the most 

items]
30. Secondary Record: [Select Delete]
31. Merge Method: [Select SUNY - Overlay All But 

Local Fields]
32. Upon No Match: [Select Do Not Import]
33. Click Next
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1. Creating a Repository Import Profile Without Inventory

34. Synchronize with OCLC: [Select Publish Bib]
35. Condition: [Select Unconditionally]
36. Click Next
37. Inventory Operations: [Select None]
38. Click Save
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2. Copy the OCLC Numbers to a .txt File

1. Open a text editor, such as Notepad or Notepad+++
2. Paste the OCLC numbers into the text editor

o Must not contain the (OCoLC) prefix

3. Click File>Save
4. Select the path where the file will be saved
5. Name the file
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3. Batch import the OCLC number to Alma

1. Open Connexion Client
2. Click Batch>Enter Bibliographic Search Keys
3. Click Import
4. Select the .txt file
5. Click "No" when the pop-up screen appears and asks "Do you want to delete your original import profile"
6. Click Save
7. Click Close
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4. Batch Load the MARC Records to a Local Save File

1. Click Batch>Process Batch
2. Check the box next to the default bib file path (or to custom path if configured)
3. Check the box next to Online Searches under Process
4. Click Ok

o Files will upload to the save file

5. Batch Search Report will display when the upload is complete
6. Click the "X" to close the Batch Search Report



www.suny.edu

5. Export the MARC records in the local save file to a file

1. Go to Tools>Options
2. Click on the Export tab
3. Click on the file export being used

o Create a file export if one does not already exist
4. Click Apply
5. Click Close
6. Click Cataloging>Search>Local Save File (F3)
7. Use the default file path unless the user selected a customized save file to batch upload
8. Click OK
9. The MARC records will display
10. Click the Export icon (Actions>Export F5)
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6. Rename the File from .dat to .mrc

1. Open the file manager on your computer
2. Go to the path where the file was created based on the file export in OCL
3. Right-click on the file 
4. Click Rename
5. Change .dat to .mrc

o Optional: change the whole name as well as the file extension 
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7. Import the .mrc File into Alma Using the IZ Repository Import Profile

1. Go to Resources>Import>Manage Import Profiles
2. Select Run from the ellipses of the import profile created to import OCLC batch files
3. Click Select File
4. Click on the file icon to select the .mrc file
5. Click Add
6. Click Submit
7. The job will run
8. Review the job report after the job is complete



SUPPORTING 
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Supporting Documentation

SUNY:
o Why are diacritics displaying strangely in Alma and Primo VE from an OCLC record I 

exported?
o Our diacritics are not displaying correctly in Primo VE. What should we do?
o How do batch export bibliographic (bib) records from OCLC to Alma?

Ex Libris:
o Special characters and diacritics appear corrupted in records imported from OCLC 

Connexion into Alma
o Alma Indication Rule for Bad Diacritics
o How to ensure correct display of diacritics in Connexion imports
o How to Import Special Characters in Alma

https://slcny.libanswers.com/faq/270567
https://slcny.libanswers.com/faq/246405
https://slcny.libanswers.com/faq/351629
https://knowledge.exlibrisgroup.com/Alma/Knowledge_Articles/Special_characters_and_diacritics_appear_corrupted_in_records_imported_from_OCLC_Connexion_into_Alma
https://developers.exlibrisgroup.com/blog/alma-indication-rule-for-bad-diacritics/
https://knowledge.exlibrisgroup.com/Alma/Knowledge_Articles/How_to_ensure_correct_display_of_diacritics_in_Connexion_imports
https://knowledge.exlibrisgroup.com/@api/deki/files/50565/Misc_-_How_to_input_special_characters_in_Alma.pptx?revision=1

